Ethereum network is currently working under optimal level

Incident Report for CoinGate

Resolved

This incident has been resolved.
Posted Feb 01, 2023 - 19:53 UTC

Update

Same issue is experienced with Binance Chain. We are working to identify the issue
Posted Feb 01, 2023 - 18:14 UTC

Investigating

Ethereum network is experiencing a partial outage
Posted Feb 01, 2023 - 18:07 UTC
This incident affected: Payment Services (Other Cryptocurrencies).